Sfogliare condivisioni Windows con Xubuntu

Informatica

Stasera, cercando di accedere dal mio iMac G3 (su cui gira Xubuntu 7.10 PPC) alla mia home directory condivisa tramite Samba dal mio PC (su cui gira Mandriva Linux), ho scoperto l'ennesima applicazione di FUSE, fusesmb, che permette di sfogliare le cartelle condivise in rete come se fossero cartelle locali.

Come sapete, Samba è un'implementazione per Linux (e Mac Os X, e...) del protocollo SMB, usato dai sistemi MS Windows per condividere cartelle e file in rete. Io l'avevo attivato sul mio PC per scambiare facilmente file con alcuni notebook su cui girava Windows XP. Ma già che l'ho configurato, perché non continuare ad usare Samba anche per scambiare file con l'iMac?

Un modo semplice di usare Samba è usare i client inclusi in Nautilus (il file manager predefinito di Gnome) o in Konqueror (il file manager tuttofare di KDE). Non conosco bene Gnome, ma so bene KDE supporta in un modo veramente ottimo lo scambio di file tramite SMB: basta digitare smb:// e poi il nome della condivisione a cui vogliamo connetterci, oppure sfogliando la rete da "cartelle di rete".

Purtroppo Thunar, il file manager predefinito di XFCE, l'ambiente grafico minimale usato da Xubuntu, non suppporta ancora l'accesso a condivisioni Samba. OK, possiamo sempre montarle a mano usando la riga di comando (sudo smbmount...)... ma noi vogliamo qualcosa di più semplice, e accessibile da tutti gli utenti, giusto?

La risposta è fusesmb. fusesmb, una volta attivato e configurato, monta automaticamente tutte le condivisioni SMB a cui tentiamo di accedere, permettendoci di interagire con esse come se fossero delle normalissime cartelle (forse un po' più lente da leggere). Il vantaggio principale in questo è che nel nostro normale lavoro non dobbiamo ricorrere a nessun altro programma per montare o smontare le condivisioni, e che tutti i nostri programmi potranno lavorare con i file contenuti nelle condivisioni esattamente come se fossero dei file locali (!).

Vi ho annoiato a sufficienza, ora passiamo all'azione.

Come installare fusesmb? Niente di più semplice. Usiamo il gestore dei pacchetti Synaptic (il nome del pacchetto è appunto fusesmb), oppure usiamo il comando "sudo apt-get install fusesmb".

Da una segnalazione precedente, e da nuovi esperimenti, ho notato che installare il solo pacchetto fusesmb non è sufficiente per far funzionare il sistema: dobbiamo installare anche i pacchetti smbclient e samba-common, utili anche per eventuali scopi diagnostici:
sudo apt-get install smbclient samba-common
Durante l'installazione, ci verranno chiesti dei parametri relativi alla nostra rete. Se si tratta di una rete domestica, rispondiamo dando il nome del nostro workgroup (di default "WorkGroup").

Poi dobbiamo assicurarci che il sistema carichi il modulo fuse all'avvio del computer. Per far questo, aggiungiamo una riga contenente la parola "fuse" in coda al file /etc/modules. Per far questo dobbiamo eseguire il nostro editor di testo tramite sudo (ad esempio, usando il comando "sudo mousepad /etc/modules" oppure "sudo nano /etc/modules". Per caricare il modulo fuse subito senza aspettare di riavviare il computer basta eseguire il comando "sudo modprobe fuse".

Ora, se il sistema non ha già provveduto, creiamo un nuovo gruppo chiamato "fuse" (sudo groupadd fuse) e aggiungiamo a questo gruppo tutti gli utenti che desideriamo abbiano accesso alle funzionalità di fusesmb. Un modo facile per far questo è andare al menu di XFCE, sottomenù "Sistema" e infine "Utenti e Gruppi". Da riga di comando si ottiene lo stesso risultato con un comando tipo "usermod -a -G fuse nomeutente".

A questo punto dobbiamo creare una directory vuota da usare come punto di montaggio per fusesmb. La possiamo mettere dove ci pare, io l'ho messa in /media/network. Per crearla uso il comando "sudo mkdir /media/network" e poi imposto i permessi con il comando "sudo chmod 777 /media/network" (se non abbiamo confidenza con il terminale, possiamo usare "sudo thunar").

Facciamo il login e poi di nuovo il logout, in modo che la nostra aggiunta al gruppo fuse sia effettiva.

Attiviamo fusesmb eseguendo in un terminale il comando "fusesmb /media/network". A questo punto se proviamo a visitare la cartella /media/network, vi vedremo elencate le nostre condivisioni, che possiamo navigare normalmente, come fossero cartelle locali.
Se vogliamo disabilitare fusesmb, basta che diamo il comando "fusermount -u /media/network" (come per tutti gli altri file system virtuali che si appoggiano a FUSE).

Per far sì che fusesmb si attivi automaticamente al nostro login, andiamo al menu di XFCE, "Impostazioni", "Autostarted applications" e aggiungiamo una nuova voce di avvio. Nel campo "comando" inseriamo "fusesmb /media/network", mentre negli altri campi possiamo scrivere quel che preferiamo.

Potrebbe servirci connetterci ad alcune condivisioni che richiedono autenticazione. Per questi casi, consultando la pagina man di fusesmb.conf, ho visto che basta creare nella nostra home il file ~/.smb/fusesmb.conf, e inserire delle righe tipo queste:

[/SERVER/SHARE]
username=john
password=doe

Chiaramente, al posto di /SERVER/SHARE inseriamo il nome della condivisione che richiede autenticazione, e al posto di "john" e "doe" inseriamo nome utente e password pertinenti.
Possiamo aggiungere delle righe analoghe per tutte le condivisioni a cui vogliamo accedere che richiedano autenticazione.

Per ragioni di sicurezza consiglio di modificare i permessi di ~/.smb/fusesmb.conf, in modo che sia accessibile il lettura/scrittura solo al nostro utente e a nessun altro (non vogliamo certo esporre le nostre password al mondo intero, vero???).

È stato facile, vero? Ed è ancora più facile usarlo, non è vero? (praticamente non ce ne accorgiamo...)
Concludendo, giusto per pignoleria devo dire che nessuno ci impedisce di usare fusesmb anche su computer con Gnome o KDE, se lo preferiamo ai sistemi di accesso alle condivisioni SMB predefiniti di questi ambienti grafici. Come sempre, sta a noi la scelta di come vogliamo far funzionare il nostro sistema GU/Linux!

Trackback URL for this post:

http://gerlos.altervista.org/trackback/263

commenti

ritratto di vincenzo

problema fusesmb

ho seguito tutti i punti da te suggeriti, non riesco però a modificare ~/.smb/fusesmb.conf per inserire nome utente e password...quando lancio il comando da terminale mi dice permesso negato
inoltre riprovo a modificare i permessi della cartella media/network , come fatto appena creata la cartella e mi da lo stesso errore
sono in una lan di windows, riesco ad accedervi, e non ho problemi con i pc win....
l'unico pc che necessita di autenticazione ha installato ubuntu (e a dirla tutta, è l'unico pc al quale dovrei attingere per le risorse di rete)
hai qualche suggerimento da darmi?

ritratto di gerlos

problema fusesmb

"Chi" ti risponde "permesso negato"? Come fai a modificare il file ~/.smb/fusesmb.conf?

Se non ce l'hai già lo devi creare, basta che prima crei la directory nascosta ".smb" (se non lo sapessi, i file e le cartelle il cui nome comincia per punto sono nascoste in linux), inserisci il testo in un qualsiasi editor, come ad esempio mousepad o gedit, e poi salvi il file in /home/nomedeltuoutente/.smb/fusesmb.conf.

La directory /media/network la riesci a creare?
Sicuro che l'utente con cui lavori sia configurato per usare sudo? (in *Ubuntu dovrebbe essere così di default, ma non si sa mai)

Per poterti aiutare davvero dovresti postare *esattamente* i comandi che dai e l'output che ne ricevi. Di solito il terminale è generoso di indicazioni su come risolvere un problema.
Capisci da te che dire "mi dice permesso negato" non è di molto aiuto per risolvere il problema...

ritratto di gerlos

problema fusesmb

Installando fusesmb su una Debian Etch ho constatato che per farlo funzionare è necessario installare *anche* il pacchetto samba-common. Probabilmente fusesmb legge alcune informazioni dal file di configurazione di samba, che in assenza di questo pacchetto non esiste.
Ho aggiornato questa pagina consigliando di installare anche smbclient, che è molto utile per montare le condivisioni "difficili" e per scopi diagnostici.

ritratto di fafo

Grandioso

tutto perfetto, ottimo. Sai se funziona anche su OS X 10.5?

ritratto di fafo

Re: Grandioso

lascia perdere la domanda, era stupida.

ritratto di gerlos

Re: Re: Grandioso

Da quando esiste macfuse (http://code.google.com/p/macfuse/ ) dovrebbe funzionare, sì.

Almeno, dovrebbe funzionare se sei in grado di compilare fusesmb anche sotto mac os x.

Sicuramente funzionano sshfs (gran cosa!) ed encfs (fantastico!), poi è solo questione di provare, imho.

Ma che te ne fai con Mac Os X? Il supporto a SMB dovrebbe già essere ottimo, almeno le volte che l'ho usato mi ha fatto un'ottima impressione.

ritratto di Ballard

Problemi a rinominare file con Thunar

Ciao Gerlos,
innanzitutto complimenti per la guida che mi è stata molto utile. Seguendo le tue indicazioni sono riuscito a configurare il tutto nella mia installazione di Xubuntu ed ora con Thunar riesco a vedere anche le condivisioni di Window e ora ho solo un piccolo problema che forse potresti aiutarmi a risolvere:

Se da terminale faccio il listato dei file contenuti sotto la mia condivisione WIndow mi ritrovo una riga di questo genere:
[email protected]:/media/network/WORKGROUP/PC-ALESSANDRO/CONDIVISIONE_WINDOW$ ls -l
totale 0
-rwxr--r-- 1 alessandro alessandro 0 2008-07-06 13:47 PROVA.TXT

Se utilizzando Thunar rinomino il file PROVA.TXT in PROVA2.TXT l'icona del file sparisce e se faccio di nuovo da terminale il listato del contenuto della cartella con la condivisione Window mi ritrovo una risposta di questo genere.

[email protected]:/media/network/WORKGROUP/PC-ALESSANDRO/CONDIVISIONE_WINDOW$ ls -l
ls: impossibile accedere a PROVA2.TXT: Nessun file o directory
totale 0
-????????? ? ? ? ? ? PROVA2.TXT

In altre parole è come se l'utilizzo di Thunar andasse ad alterare i permessi sul file. Hai qualche suggerimento da darmi per risolvere il problema!?

Grazie e cordiali saluti

ritratto di gerlos

Re: Problemi a rinominare file con Thunar

Scusa se ti rispondo solo adesso, sono stato a lungo fuori città e non avevo accesso a internet.

Non so a cosa potrebbe essere dovuto il tuo problema, le cause potrebbero essere tante, ma in prima battuta io proverei a creare, rinominare e cancellare file usando il terminale, e poi thunar, in modo da delimitare meglio il problema.

Fai così: apri un terminale, spostati in una directory della condivisione windows, e prova a manipolare un po' di file da riga di comando. Ad esempio, prova questi comandi:
cd /media/network/WORKGROUP/PC-ALESSANDRO/CONDIVISIONE_WINDOW
touch unfilediprova
mv unfilediprova altrofilediprova
cp altrofilediprova ancorafilediprova
echo testo di prova > unfiledaleggere
cat unfiledaleggere
ls -l
rm altrofilediprova ancorafilediprova unfiledaleggere

Posta l'output di questi comandi, così sarà più facile aiutarti, ok?
Già che ci sei, puoi postare l'output del comando umask?

Inoltre, supponendo che il file di configurazione ~/.smb/usesmb.conf sia ok (controlliamo?), sei sicuro di aver configurato le cose sulla macchina windows in modo che l'utente che usi per accedere via samba sia in grado di scrivere in quella cartella condivisa?

Usi Windows XP Home, Professional? Oppure usi Windows Vista?
Ricordo che i permessi in windows sono parecchio involuti e più complicati rispetto ai permessi unix, e a volte accadono cose strane.

Se tutte queste cose (configurazione di windows, comandi da terminale) sono ok, allora il problema è proprio su Thunar, e ci dobbiamo concentrare proprio su di lui. Purtroppo dal poco che mi hai detto non sono in grado di saperlo in anticipo!

Fammi sapere.

ritratto di Spa

Al reboot non carica la condivisione..

Ciao ho un problema... ho seguito la guida e son riuscito ad abilitare la condivisone. il problema nasce però quando hpo riavviato (e poi sempre) , che non carica la condivisione. Succede questo: vado in media/network e la cartella è vuota. Allora provi a montare ancora la cartella con fusesmb /media/network e la cartella sparisce.
Mi sono accortro però che digitando con il terminale thunar e andando in media network vedo le condiuvisioni!! ... come mai ?! (confused) .

preciso che in etc/modules c'è la voce fuse e ho dato i permessi sudo chmod 777 /media/network
... sembra ci siano problemi sui gruppi ??

.............. chi mi aiuta?

ritratto di Spa

continuazione...

Sempre io, dopo aver fatto alcuni test, scopro che la cartella /media/netwok la visualizzo solo avviando Thunar -.-

ps: ho verificato pure che nel gruppo fuse ci fosse il mio nome utente, ed è inserito....

non so come risolvere :(

ritratto di Aleangel14

Crash cartella network

Sono un nuovo utente Xubuntu..dopo un anno di uso costante di Kubuntu.
Passare dal Kde all'Xfce(a causa della ormai veneranda età 256mb ram P4 2.8Ghz ) non è stato facile..comunque la difficoltà maggiore l'ho riscontrata nella esplorazione delle cartelle di un Desktop remoto(Windows XP) connesso al portatile tramite un router. Dopo aver eseguito la tua guida riesco ad esplorare poi con il file manager del portatile la mia rete. Però quando arrivo agli hard disk del Desktop e cerco di aprirli mi esce questo messaggio

Il punto di termine del trasporto non è connesso.

e la cartella in network sparisce nella sezione \media\ sparisce..e l'unico modo per farla riapparire è disabilitare e di abilitare fusesmb con questo codice da terminale

Codice:
fusermount -u /media/network
fusesmb /media/network

Invece se esploro la rete del Desktop da terminale..non ho alcun problema riesco a visualizzare tutte le cartelle senza problemi..
Vi riporto anche la sezione "Configuration" del programma GADMIN
-SAMBA che ho usato per configurare il file /etc/samba/smb.conf

Codice:
[global]
netbios name = Samba24
[STRACUT]

Il mio router ha l'indirizzo 192.168.1.1
il desktop 192.168.1.2
il portatile 192.168.1.3

Grazie in anticipo

ritratto di gerlos

Re: Crash cartella network

Mi sono permesso di rimuovere il lungo testo di samba.conf che avevi postato, perché la configurazione del server samba SUL computer gnu/linux che usi per accedere alla condivisione su Windows XP è irrilevante. SE NON ti interessa accedere DA Windows A directory condivise sulla tua linuxbox, puoi anche disattivare il servizio samba sul tuo sistema.
Ricorda sempre la distinzione server/client: nel caso che citi, Windows XP fa da server, e la tua linuxbox fa da client. Dunque la configurazione del server samba sulla linuxbox è irrilevante. Sono da controllare la configurazione del server Windows XP (ad esempio, i permessi delle directory) e la configurazione del client fusesmb.

Chiarito questo, mi dovresti dare altri chiarimenti, in modo che io possa aiutarti (sai, la sfera di cristallo è in riparazione...).
Mi dici che riesci a "esplorare" la rete, ok... riesci a vedere il contenuto di qualche directory condivisa? Il problema si manifesta solo con la directory desktop dell'utente di windows, o anche con altre directory?
Che file manager usi? Thunar? Rox? Konqueror? Dolphin?
Non ho capito poi cosa sparisce: sparisce /media/network, oppure /media/network/condivisione? (dove condivisione è il nome della condivisione connessa)
Da quel che mi pare di capire, non c'è nessun crash...

Potrebbe essere molto di aiuto provare ad accedere alla condivisione tramite riga di comando, usando smbclient o montando la condivisione con smbmount. Di solito la riga di comando dà messaggi di errore più espliciti e più chiari, che aiutano a orientarsi.
Puoi usare la riga di comando anche per navigare le condivisioni montate automaticamente con fusesmb. Che cosa accade quando fai cd nella directory del desktop a cui vuoi accedere?
Hai provato ad accedere tramite konqueror? (il file manager di KDE) Funziona?

Un'ultima considerazione, in attesa dei tuoi chiarimenti. Non sottovalutare il tuo Pentium 4!!! Io ne ho uno ancora meno potente (2.6 GHz) su cui faccio fotoritocco "pesante" (pensa che lavoro con immagini a 8 Mpx e spesso creo panorami da 15 o 20 Mpx, facendoti un giro per il mio sito te ne puoi fare un'idea) con l'ultima mandriva (una distribuzione gnu/linux più o meno equivalente a *Ubuntu)!

Quel che fa la differenza è la RAM disponibile... 256 MB sono veramente pochini! Al giorno d'oggi le vecchie DDR si trovano in commercio a prezzi molto interessanti, ti suggerisco di spendere 2 soldi e installare sul tuo PC almeno 1 GB di RAM. L'incremento di prestazioni che vedrai sarà notevole.
Io lavoro con 2 GB di RAM e il sistema su un hard disk serial ATA, KDE 3.5 con compiz, e il mio computer è sempre molto, molto reattivo, anche perché quando non faccio lavori "pesanti" quasi tutto viene tenuto nella cache in RAM, e il sistema accede pochissimo all'hard disk in lettura.

XFCE è molto bello, ma se per te è un ripiego e non una scelta, aggiungi RAM e torna a KDE!

In attesa dei tuoi chiarimenti e sempre a disposizione.

ritratto di Aleangel14

Mi dispiace di essere stato

Mi dispiace di essere stato poco chiaro. Spero di essere esaustivo questa volta.
Accedendo alla rete con thunar, il file manager predefinito di Xubuntu, riesco ad accedere alla rete locale fino a certe cartelle. Faccio un esempio per rendere chiaro il tutto. Riesco ad accedere al mio pc remoto senza problemi fino alle cartelle /media/network/workgroup(nome della mia rete locale)/Desktop/Dati(nome dell'hard disk che uso come deposito)/ . Invece se apro uno dei file contenuto in dati oppure provo ad aprire un altra cartella salvata in essa mi appare l'errore che ti ho scritto sopra

Il punto di termine del trasporto non è connesso.

e la cartella network non c'è più nella sezione \media. Per fa riapparire la cartella network devo chiudere fusersmb e riaccenderlo. Non so se questa volta sono stato più chiaro.
Invece da terminale riesco ad accedere a tutte le cartelle della mia rete senza problemi. Tornando al mio esempio riesco anche ad accedere alla cartella , ad esempio, /media/network/workgroup/Desktop/Dati/Università.
Non ho installato Konqueror perché non volevo appesantire il mio pc. Però se sarà necessario per risolvere questo problema lo faro. Quali pacchetti dovrei installare per far partire konqueror?
Il Desktop di cui ti parlavo sopra ha 2 GB di ram DDr 2 e so perfettamente quanto è più prestante. PErò il portatile ha anche qualche problema con il lettore cd(legge malissimo sia i cd che i DVD)..ogni volta installare un nuova versione di linux è un trauma. Quindi per rimetterlo in sesto dovrei spendere ad occhio e croce 200 euro(con 2 GB di ram). Quindi ne spendo 500 e mi compro un nuovo laptop. Non credi?

ritratto di gerlos

Re: Mi dispiace di essere stato

Ciao!
Scusa per il lungo tempo per la risposta, ho avuto da fare... Dunque: ho fatto qualche prova e ho gironzolato in rete cercando risposte, ma purtroppo non sono né riuscito a riprodurre il tuo problema, né sono riuscito a trovare documentazione utile, mi dispiace!

Per installare konqueror... beh, il pacchetto si chiama proprio "konqueror":
http://packages.ubuntu.com/intrepid/konqueror
Forse ti farà tirar giù kdebase e le kdelibs, oltre alle librerie qt, che però potresti aver già installate. Tu prova, e vedi se il gioco vale la candela.

Non capisco le tue difficoltà ad aggiornare il tuo sistema gnu/linux. Non fai gli aggiornamenti via rete?

E poi... Mica c'è bisogno di reinstallare ogni volta... Se ricordo bene (ultimamente uso più debian e mandriva), quando esce una nuova release ubuntu ti avvisa proponendoti un "avanzamento" di versione. In questo modo scarichi solo quel che ti serve, e se la procedura si interrompe la puoi continuare in qualsiasi momento. Se non hai la rete, sicuramente hai una pendrive usb, e saprai che se il tuo computer può fare il boot da usb puoi anche avviare una installazione da lì:
https://help.ubuntu.com/community/Installation/FromUSBStick

Io non reinstallo più o meno dal 2000, ogni sei-otto mesi circa aggiorno le mie distribuzioni via rete.

ritratto di Roberto

Stesso problema

Ciao. Anche io ho esattamente il tuo stessa problema con Xubuntu installato su una vecchia macchina (Celeron 800 con 480 MB di ram). Ho seguito alla perfezione la guida, ma una volta che riesco ad accedere alla rete Windows se provo ad aprire qualche file o qualche cartella viene riportato l'errore che hai già detto tu e la cartella Network sparisce. Ho provato anche con Konqueror ma succede la stessa cosa. Non so che fare, magari proverò con qualche altra distribuzione per macchine datate.
Roberto

ritratto di matteo

il punto di termine del trasporto non è connesso

A me così poi ha funzionato. non chiedrmi perchè
Anche a me dopo poco spariva la condivisione, ho provato con fusesmb -s e tutto è andato bene!!!!

ritratto di eleu

cercavo da tempo una

cercavo da tempo una soluzione al problema di Nautilus che non monta filesystem SAMBA in cartelle navigabili dagli normali utenti. in nautilus riesco a raggiungere la condivisione con CTRL+L smb://NOMEGRUPPOWINDOWS;[email protected]/nomecondivisione/ ma rimane impossibile es. allegare a mail dei file che stanno su samba. ho provato fusesmb, ma $ls -R /media/network/ mi restituisce una directory vuota. la condivisione SAMBA a cui devo accedere necessita autenticazione, ho inserito /NOMESERVER/NOMECONDIVISIONE in fusesmb.conf ma forse nella forma sbagliata. qualcuno ha consigli? grazie mille, in ogni caso, per l'ottima guida.

ritratto di gerlos

Re: cercavo da tempo una

Dal fatto che accedi alla directory da nautilus deduco che nella tua rete samba funziona.

Puoi postare qui il contenuto del file ~/.smb/fusesmb.conf presente nella tua home? Dovrebbe somigliare a questo:
[/SERVER/SHARE]
username=john
password=doe

Mi raccomando, non riportare la tua password vera!!!

ritratto di csl2

ecco qui. nel frattempo ho

ecco qui. nel frattempo ho cercato di usare un tool grafico, fusesmbtool, ma non e' cambiato granche'. il fatto e' che su un server (servera) come sull'altro (lamantino) ho diverse partizioni montate via samba, che richiedono autenticazioni diverse. come utente globale non ho messo nulla, appunto perche' sono utenti diversi... non vorrei dover usare smb4k!

### configuration file for fusesmb ###
### Written by Fusesmbtool ###
#global options

[global]

; List hidden shares
showhiddenshares=true

; General username
username=

; General password
password=

; Connection timeout in seconds
timeout=10

;Interval for updating new shares in minutes
interval=10

#specific options

; Servers/Share specific settings
[GRUPPOALEKOS/LAMANTINO/serverdati]
username=jon
password=doe
showhiddenshares=true
ignore=false

; Servers/Share specific settings
[servera]
username=jon2
password=doe2
showhiddenshares=true
ignore=false

#Todo....

ritratto di gerlos

Re: ecco qui. nel frattempo ho

Mi dispiace che non ti ho potuto rispondere prima, ho esaminato il tuo file di configurazione, e non riesco a dire cos'è che non va. Mi dispiace veramente ma non sono in grado di aiutarti!

Hai provato a contattare qualche sviluppatore del progetto fusesmb o samba? Lì c'è gente molto in gamba e disponibile che potrebbe saperti indicare dove guardare e dove intervenire per risolvere il problema.

ritratto di MArCoS

http://bugs.debian.org/cgi-bi

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497572
prova ad usare smbnetfs io ho risolto cosi..risolto per modo di dire in quanto se mi restituisce qualche errore un qualunque file sulla condivisione(tipo un unzip di un file corrotto) ricrasha che è una bellezza.
ciao

ritratto di Robinlinux

Problema con cartella network

Buon giorno a tutti vi scrivo in quanto ho un singolare problema con fuse.
Tutto funziona fino a quando opero con root.. se mi sposto con l'utente che appartiene al gruppo fuse.. non vedo + nulla..

La cosa strana è che fino a quanto fuse non è attivo la cartella network la vedo senza problema, appena attivo fuse sparisce..

Immagino che sia una problema di permessi ma non riesco a capire dove..

Attendo una vostra gentile risposta.

RobinLinux

ritratto di Andrex

Anche a me dopo poco spariva

Anche a me dopo poco spariva la condivisione, ho provato con fusesmb -s e tutto è andato bene!!!!

ritratto di Massinge

TUTTO OK!

Ottima guida! Anche io però ho sostituito in avvio automatico la stringa con questa:
fusesmb -s /media/network
e tutto va a meraviglia (prima avevo gli stessi problemi che lamentavano negli ultimi post).
Utilizzo Xubuntu10.04

Invia nuovo commento

Il contenuto di questo campo è privato e non verrà mostrato pubblicamente.
  • Allowed HTML tags: <a> <em> <strong> <del> <cite> <code> <img> <ul> <ol> <li> <dl> <dt> <dd> <pre>
  • Linee e paragrafi vanno a capo automaticamente.
  • Insert Flickr images: [flickr-photo:id=230452326,size=s] or [flickr-photoset:id=72157594262419167,size=m].
  • Indirizzi web o e-mail vengono trasformati in link automaticamente

Maggiori informazioni sulle opzioni di formattazione.

CAPTCHA
Per provare che sei un visitatore umano, rispondi a questa domanda. È per evitare l'inserimento di messaggi spam.
Image CAPTCHA
Enter the characters shown in the image without spaces, also respect upper and lower case.